Moxie Support of Oracle JRE (Java Runtime Edition)

Oracle Java (JRE) version support

Oracle (previously, Sun Microsystems) owns, develops and supports the Java (JRE) software used as a platform for Moxie's Agent Client. The JRE platform is continuously evolving and changing. Moxie attempts to support the latest version of JRE whenever possible.

Moxie's most current releases support 32-Bit JRE 1.8 (Also known as Java 8) only

Moxie supports 32-Bit JRE 1.7 (java 7) for some older Moxie releases. These updates the information found in Moxie's Hardware and Software Requirements guides and release notes for your specific version.

Java 1.9 is not currently supported
 

Moxie tests the latest generally update available (such as Java 1.8 update 101) when Moxie releases an product update.   

Since JRE 1.7 Update 51, was released, JRE sets the default security level in JRE higher than in past versions.  This may require updates to support these later versions of JRE. 

 

JRE 1.8 update 121 was tested in the Agent Client with the following Channels version:

  • Channels 9.4 Cumulative Update 7 QFE 5

 

JRE 1.8 update 40 was tested in the Agent Client with the following Channels version:

  • Channels 9.2 Hotfix 1 Patch 8

JRE 1.8 update 45 was tested in the Agent Client with the following Channels version:

  • Channels 9.1 Hotfix 3 Patch 5

 

JRE 1.7 update 80 was tested in the Agent Client with the following Channels version:

  • Channels 9.4 Hotfix 1 Patch 3

JRE 1.7 update 75 was tested in the Agent Client with the following Channels version:

  • Channels 9.1 Hotfix 3 Patch 5   

JRE 1.7 update 80  was tested in the Agent Client with the following Channels version:

  • Channels 9.2 Hotfix 1 Patch 8

 

Important items to note

  • There are 64-Bit and 32-Bit versions of JRE. Moxie currently only supports 32-bit versions.
     
  • The 32-Bit version of JRE requires the 32-bit Version of Internet Explorer.
     
  • Running 32-bit ActiveX controls in a 64-bit IE is not supported. Refer to the Microsoft article on this topic (http://support.microsoft.com/kb/896457).
     
  • JRE 1.6 is currently supported versions for Moxie versions prior to 9.1.0.2 Patch 6.
     
     
  • The Java Automatic Updater Utility will attempt to automatically download and install version 1.7 if 1.6 or an older update of 1.7 is installed. If 1.7 is installed via auto-update, 1.6 will automatically be uninstalled. In enterprise applications, it is generally not recommended to have software automatically update from the client. We do recommend monitoring Oracle for JRE updates as they are frequently addressing security issues.
     
  • Please note that while JRE supports running versions 1.6 and 1.7 concurrently, there are known issues and this configuration is not supported until  or if Oracle resolves this issue in a future update. (Moxie’s Agent Client will automatically utilize Java 1.6 in this scenario. Refer to Oracle articles on this topic http://bugs.sun.com/view_bug.do?bug_id=8019167) and (http://bugs.sun.com/view_bug.do?bug_id=8020595).
     
  • Since JRE 1.7 Update 51 and JRE 1.8 Update 20 were released, JRE sets the default security level in JRE higher than in past versions.  This may require updates to support these later versions of JRE.
     

 

Moxie JRE Support Statement

Moxie does extensive testing on specific JRE (Java Runtime Environment) versions with every major/minor release using the latest releases available at the time. Specified tested and certified versions are documented in the hardware/software recommendations guide and other release documentation.

Moxie will support generally available JRE versions within a specific major Java version, as documented with each release. For example, in version 9.4 CU7, Moxie supports
JRE 1.8 (Update 65 is not recommended). Moxie recommends that customers test versions of JRE before deployment in production. If a specific update is found to have issues, the exclusion will be documented.

 

If you have additional questions, please contact our Support group at +1-877-373-7848 (option 2) or via email at support@gomoxie.com.